Profile: henry

Avatar
Statistics
hi-level in

can i use just one speaker for both inputs for my hi-level input?

4 months ago

i am thinking of doing a blow thru in my reg cab 07 chevy silverado when the new 95's come out.  what box would you recommend for good loud deep rap/hip hop bass.  i have been debating on doing a ported or bandpass enclosure.  what would be the pros and cons of doing ported or bandpass.  i am not really interested in cutting out the entire back wall but if its what i needed to do i can.

4 months ago

finally got around to check out my stereo.  turns out my gain was to high and the rca was loose at the amp.  thanks for help.

5 months ago

the amp does seem to go into protect mode.  i checked my subs and i think i have a bad coil.  one is reading 1.8ohm and the other is reading about 29.  the second sub is reading 1.8 on each coil so that should be ok.   i do have dual 2ohm subs so i guess i will purchase a new sub when i can.  

5 months ago

jason, thanks for the tips.  when i get home tonight i will try out your tips to see if it will fix my stereo.

5 months ago

in order to wire your subs there are a couple different ways.  i had a similar question and the guys at MTX support gave me this link to help out with wiring.  just select the number of subs you have and the impedance of the coil(s).  then there will be a diagram on how to wire it.  make sure your amp can work with the total you end up with.
https://www.mtx.com/t/library-wiring-diagrams

5 months ago

i recently installed a 4-ch and sub amp into my car and i now have a whining noise whenever my car is on.  it gets louder when i accelerate.  also it only comes out of the front speakers.  it is not there when my car is off.  my ground is about 8" long and goes to the floor of the trunk and is scratched, shiny metal using my own screws and star washer.  power and signal wires are ran on different sides of the car.  what can i do to fix my audio.  its loud like i like it but i do not like the whine.  please help me!!


my stereo setup:
Kenwood excelon KDC-X597 (replaced the excelon KDC-X395)
MTX Thunder 75.4
Alpine MRX-110
MTX TX6 components
Kicker CS693 rear speakers
MTX Thunder 8000 subs 12"x2
StreetWires ZN5 power wires
StreetWires ZN5 RCA cables

all installed in a 2001 Toyota Camry

5 months ago

i have 2 8000 series 12" subs and when i play them for about 15 min they will then stop playing for about 2 minutes and then play for about another 12 min then stop for about 2 more minutes.  i have the alpine mrx-m110 amp and it is about 1month old.  what is happening with my subs?  the amp does not turn off when the subs stop.

5 months ago